現在のページの位置: くろねこスクエア Labs > LGM

くろねこスクエア Labs

Lightweight Google Maps(API V3対応) 1.40.2

Lightweight Google MapsをAPI V3対応にするという件の修正です。「カテゴリから絞る」際の動作の改良と、新規サイトで導入できなかった点の修正です。

  • (新規サイトで)API-Keyが設定されていない場合に動作しない不具合を修正
  • 固定地図ページで「カテゴリから絞る」機能の挙動を修正

Lightweight Google MapsをAPI V3対応にする

WordPressのプラグインでLightweight Google Mapsというのがあります。Google Mapを表示するのに便利なのですが、現行のGoogle Maps JavaScript API バージョン3(V3)に対応していません(プラグイン本体が2008年から更新されていないようです)。

V2はサポート終了しており、既存サイトの場合はV2を使っている地図が下位互換機能を持たせたV3の地図に自動的に切り替わります。しかし新規サイトの場合はAPI-Keyが発行されないためにプラグインを利用できないことが判明。もったいないのでV3用に書き換えてみました。なお開発版でバグなどあると思いますので、ご注意ください。

本家バージョンに上書きして動かない場合は、一度プラグインの設定を保存し直すと動くかもしれません。

カテゴリー

Feed

メタ情報