現在のページの位置: くろねこスクエア Labs > 未分類 > Lightweight Google MapsをAPI V3対応にする

くろねこスクエア Labs

Lightweight Google MapsをAPI V3対応にする

WordPressのプラグインでLightweight Google Mapsというのがあります。Google Mapを表示するのに便利なのですが、現行のGoogle Maps JavaScript API バージョン3(V3)に対応していません(プラグイン本体が2008年から更新されていないようです)。

V2はサポート終了しており、既存サイトの場合はV2を使っている地図が下位互換機能を持たせたV3の地図に自動的に切り替わります。しかし新規サイトの場合はAPI-Keyが発行されないためにプラグインを利用できないことが判明。もったいないのでV3用に書き換えてみました。なお開発版でバグなどあると思いますので、ご注意ください。

本家バージョンに上書きして動かない場合は、一度プラグインの設定を保存し直すと動くかもしれません。

コメントをどうぞ

XHTML: 次のタグを使用できます: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> <img localsrc="" alt="">

カテゴリー

Feed

メタ情報